И. В. Сухарева объектно-ориентированное программирование лабораторный практикум




НазваниеИ. В. Сухарева объектно-ориентированное программирование лабораторный практикум
страница2/9
Дата конвертации11.10.2012
Размер0.49 Mb.
ТипДокументы
1   2   3   4   5   6   7   8   9

лабораторная работа №1

Интегрированная среда разработки Borland Delphi/borland C++ Builder. Компилятор, компоновщик, отладчик. Система управления проектом




    1. Цель работы


Изучение основных элементов инструментальной среды разработки Delphi/С++ Builder. Ознакомление с понятием проекта в Delphi/C++ Builder. Получение сведений о назначении файлов проекта. Освоение приемов добавления и удаления визуальных компонентов на форму; редактирования свойств визуальных компонент с помощью инспектора объектов; добавления обработчиков событий. Получение навыков разработки проектов: компиляция проекта; запуск программы из интегрированной среды; пошаговая отладка с инспектированием значений переменных; создание, добавление и удаление модулей и форм; настройка опций проекта, настройка опций среды программирования.

    1. Программное обеспечение


Borland Delphi, Borland C++ Builder. Внешний вид и набор основных элементов среды программирования Borland Delphi и Borland C++ Builder идентичны. Библиотеки визуальных компонентов этих инструментальных сред также не имеют отличий. Поэтому студент имеет право выбрать по своему усмотрению в качестве среды разработки либо Borland Delphi, либо C++ Builder.

    1. Среда программирования Borland Delphi

      1. Проект Delphi


Любой проект имеет, по крайней мере, шесть файлов, связанных с ним. Три из них относятся к управлению проектом из среды и напрямую программистом не меняются. Вот эти файлы:

  • Главный файл проекта, изначально называется PROJECT1.DPR.

  • Первый модуль программы /unit/, который автоматически появляется в начале работы. Файл называется UNIT1.PAS по умолчанию, но его можно назвать любым другим именем, вроде MAIN.PAS.

  • Файл главной формы, который по умолчанию называется UNIT1.DFM, используется для сохранения информации о внешнем виде главной формы.

  • Файл PROJECT1.RES содержит иконку для проекта, создается автоматически.

  • Файл, который называется PROJECT1.OPT по умолчанию, является текстовым файлом для сохранения установок, связанных с данным проектом. Например, установленные Вами директивы компилятора сохраняются здесь.

  • Файл PROJECT1.DSK содержит информацию о состоянии рабочего пространства.

Если сохранить проект под другим именем, то изменят название и файлы с расширением RES, OPT и DSK.

После компиляции программы получаются файлы с расширениями:

  • DCU - скомпилированные модули

  • EXE - исполняемый файл

  • DSM - служебный файл для запуска программы в среде, очень большой, рекомендуется стирать его при окончании работы.

  • ~PA, ~DP - backup файлы Редактора.
      1. Структура среды программирования


Внешний вид среды программирования Delphi отличается от многих других приложений Windows. Среда Delphi состоит из нескольких отдельно расположенных окон. Перед началом работы приложения типа Delphi лучше минимизировать другие приложения, чтобы их окна не загромождали рабочее пространство.

Главными составными частями среды программирования Delphi являются:

  1. Редактор Форм (Form Designer)

  2. Окно Редактора Исходного Текста (Editor Window)

  3. Палитра Компонент (Component Palette)

  4. Инспектор Объектов (Object Inspector)

  5. Справочник (On-line help)



При разработке приложения в Delphi наиболее активно используются Редактор Форм (показан на рисунке 1.1) и Окно Редактора Исходного Текста (показан на рисунке 1.2).



Редактор Форм - это то место, где создается визуальный интерфейс программы в Delphi. Редактор интуитивно понятен и прост в использовании. Первоначально он состоит из одного пустого окна, которое заполняется объектами, выбранными программистом на Палитре Компонент.

В окне Редактора программист создает логику управления программой.

Палитра Компонент (рисунок 1.3) позволяет выбрать нужные компоненты для размещения их на Дизайнере Форм. Для использования Палитры Компонент достаточно первый раз щелкнуть мышкой на один из объектов и потом второй раз - на Дизайнере Форм. Выбранный объект появится на проектируемой форме. Им можно манипулировать с помощью мыши: двигать с места на место, использовать границу, прорисованную вокруг объекта для изменения его размеров. Однако, невидимые во время выполнения программы компоненты (TDataBase) не меняют своей формы.

Палитра Компонент использует постраничную группировку объектов. Внизу Палитры находится набор закладок - Standard, Additional и т.д.

Слева от Дизайнера Форм располагается Инспектор Объектов (рисунок 1.4). Информация в Инспекторе Объектов меняется в зависимости от объекта, выбранного на форме. Каждый компонент является настоящим объектом. Вид и поведение компонента можно менять с помощью Инспектора Объектов.

Инспектор Объектов состоит из двух страниц. Первая страница - это список свойств (предназначена для определения внешнего вида объекта), вторая - список событий (предназначена для определения поведения).

Страница событий связана с Редактором текста; если дважды щелкнуть мышкой на правую сторону какого-нибудь имени события, то соответствующий данному событию шаблон автоматически запишется в Редактор, сам Редактор немедленно получит фокус, что дает возможность добавить код обработчика данного события.

Последняя важная часть среды Delphi - Справочник (on-line help). Для доступа к этому инструменту нужно выбрать в системном меню пункт Help и затем Delphi Help. На экране появится Справочник, показанный на рисунке 1.5.

Справочник является контекстно-зависимым; при нажатии клавиши F1, выдается подсказка, соответствующая текущей ситуации.

В Delphi имеются инструменты, которые можно воспринимать как вспомогательные для среды программирования:

  • Меню (Menu System)

  • Панель с кнопками для быстрого доступа (SpeedBar)

  • Редактор картинок (Image Editor)

Меню можно использовать для выполнения широкого круга задач; чаще всего, для наиболее общих задач вроде открытия и закрытия файлов, управления отладчиком или настройкой среды программирования.

Пункт меню «File» включает шесть секций:

  • Первая секция дает возможность управления проектом в целом.

  • Вторая секция дает контроль над формами, модулями и компонентами проекта.

  • Третья позволяет добавлять и удалять файлы из проекта.

  • Четвертая управляет печатью.

  • Пятая секция - выход из Delphi

  • Шестая секция предоставляет список ранее редактировавшихся проектов.

Большинство операций из пункта меню «File» можно выполнить с помощью Менеджера Проекта (Project Manager), который можно вызвать из пункта меню «View».

Менеджер Проектов помогает управлять проектом. Менеджер Проектов (рисунок 1.6) разделен на две части. Верхняя - панель с управляющими кнопками. Нижняя - список модулей, входящих в проект.

Кнопки с плюсом и минусом используются для добавления и удаления файлов в проекте. Эти изменения влияют на файлы с исходным текстом, то есть, если добавить в проект модуль, то ссылка на него появится в файле с расширением DPR.

Краткое описание других кнопок:

  • Кнопка View unit - просмотр текста модуля, на котором стоит курсор.

  • Кнопка View form - просмотр формы, если есть таковая для данного модуля

  • Кнопка Options - вызов диалога настройки проекта.

Кнопка Update - сохранение изменений на диске.

Некоторые операции доступны и через SpeedBar. Данная стратегия типична для Delphi: она предоставляет несколько путей для решения одной и той же задачи.

Первые два пункта второй секции позволяют создать новую форму или новый модуль.

Пункт «New Component» вызывает диалог для построения заготовки нового визуального компонента. В результате создается модуль, который можно скомпилировать и включить в Палитру Компонент.

Пункт «Open File» открывает при необходимости любой модуль или просто текстовый файл. Если модуль описывает форму, то эта форма тоже появится на экране.

При создании нового модуля Delphi дает ему имя по - умолчанию. Можно изменить это имя с помощью пункта «Save File As».

«Save File» сохраняет только редактируемый файл, но не весь проект.

«Close File» удаляет файл из окна Редактора.

Пункт меню «Edit» содержит команды «Undo» и «Redo», которые могут быть очень полезны при работе в редакторе для устранения последствий при неправильных действиях, например, если случайно удален нужный фрагмент текста. Команды «Cut», «Copy», «Paste» и «Delete» - как во всех остальных приложениях Windows, но их можно применять не только к тексту, но и к визуальным компонентам.

Пункт меню «Search» содержит команду «Find Error» (поиск ошибки), которая поможет отследить ошибку периода выполнения программы.

Составляющие пункта меню «View»:

  • Project Manager –менеджер проекта.

  • Project Source - загружает главный файл проекта (DPR) в Редактор

  • Установка, показывать или нет Object Inspector на экране.

  • Установка, показывать или нет Alignment Palette. То же самое доступно из пункт меню Edit | Align.

  • Browser - вызов средства для просмотра иерархии объектов программы, поиска идентификатора в исходных текстах и т.п.

  • Watch, Breakpoint и Call Stack - связаны с процедурой отладки.

  • Component List - список компонент, альтернатива Палитре Компонент. Используется для поиска компонента по имени или при отсутствии мыши.

  • Window List - список окон, открытых в среде Delphi.

  • Toggle Form/Unit, Units, Forms - переключение между формой и соответствующим модулем, выбор модуля или формы из списка.

  • New Edit Window - открывает дополнительное окно Редактора. Полезно, если нужно, например, просмотреть две разных версии одного файла.

  • SpeedBar и Component Palette - установки, нужно ли их отображать.

Пункт меню «Compile» позволяет скомпилировать (compile) или перестроить (build) проект. Если выбрать Compile или Run, то Delphi перекомпилирует только те модули, которые изменились со времени последней компиляции. Build all, с другой стороны, перекомпилирует все модули, исходные тексты которых доступны. Команда Syntax Check только проверяет правильность кода программы, но не обновляет DCU файлы.

В самом низу - пункт Information, который выдает информацию о программе: размеры сегментов кода, данных и стека, размер локальной динамической памяти и количество скомпилированных строк.

Пункт меню «Run» можно использовать для компиляции и запуска программы и для указания параметров командной строки для передачи в программу. Здесь же имеются опции для режима отладки.

Пункт меню «Options» наиболее сложная часть системного меню. Это центр управления, из которого можно изменять установки для проекта и для всей рабочей среды Delphi:

  • Project - выбор установок, которые напрямую влияют на текущий проект.

  • Environment - конфигурация самой среды программирования (IDE).

  • Tools - позволяет добавить или удалить вызов внешних программ в пункт главного меню «Tools».

  • Gallery - позволяет определить специфические установки для Эксперта Форм и Эксперта Проектов и их «заготовок». Эксперты и «заготовки» предоставляют путь для ускорения конструирования интерфейса программы.

Последние три пункта позволяют сконфигурировать Палитру Компонент.

Диалог из пункта Options | Project включает пять страниц:

На странице Forms (рисунок 1.7) можно выбрать главную форму проекта. Изменения, которые Вы сделаете, отобразятся в соответствующем файле DPR.




Можно также использовать эту страницу для определения, будет ли данная форма создаваться автоматически при старте программы. Если форма создается не автоматически, а по ходу выполнения программы, то для этого нужно использовать процедуру Create.

На странице Applications можно задать заголовок (Title), файл помощи (Help file) и пиктограмму (Icon) для проекта.

Страница Linker показана на рисунке 1.8.



Страница Directories/Conditionals дает возможность расширить число директорий, в которых компилятор и линковщик ищут DCU файлы.

В файле DELPHI.INI содержится еще один список дире

кторий. В OPT файле - список директорий для конкретного проекта, а в файле DELPHI.INI - список относится к любому проекту.

  • Output directory - выходная директория, куда складываются EXE и DCU файлы, получающиеся при компиляции.

  • Search path - список директорий для поиска DCU файлов при линковке. Директории перечисляются через точку с запятой;

  • Conditional defines - для опытного.

Пункт меню «Environment Options ...» предоставляет большой набор страниц и управляющих элементов, которые определяют внешний вид и работу IDE. Delphi позволяет сделать следующие важные настройки:

  1. Определить, что из проекта будет сохраняться автоматически.

  2. Можно менять цвета IDE.

  3. Можно менять подсветку синтаксиса в Редакторе.

  4. Можно изменить состав Палитры Компонент.

  5. Указать “горячие клавиши” IDE.

Первая страница пункта меню «Environment Options» показана на рисунке 1.9.

В группе «Desktop contents» определяется, что будет сохраняться при выходе из Delphi. Если выбрать Desktop Only - это сохранит информацию о директориях и открытых окнах, если выбрать Desktop And Symbols - это сохранит то же самое плюс информацию для браузера.

В группе «Autosave options» указывается, что нужно сохранять при запуске программы. Если позиция Editor Files выбрана, то сохраняются все модифицированные файлы из Редактора при выполнении команд Run|Run, Run|Trace Into, Run|Step Over, Run|Run To Cursor или при выходе из Delphi. Если позиция Desktop выбрана - сохраняется рабочая среда при закрытии проекта или при выходе из Delphi.

Редактор Картинок, показанный на рисунке 1.10, работает аналогично программе Paintbrush из Windows. Получить доступ к этому модулю можно, выбрав пункт меню Tools | Image Editor.
      1. Инструментальные средства


В дополнение к инструментам, рассмотренным выше, существуют пять средств, поставляемых вместе с Delphi. Эти инструментальные средства:

  • Встроенный отладчик

  • Внешний отладчик (поставляется отдельно)

  • Компилятор командной строки

  • WinSight

Данные инструменты собраны в отдельную категорию не потому, что они менее важны, чем другие, но потому, что они играют достаточно абстрактную техническую роль в программировании.

Отладчик позволяет пройти пошагово по исходному тексту программы, выполняя по одной строке за раз, и открыть просмотровое окно (Watch), в котором будут отражаться текущие значения переменных программы.

Встроенный отладчик, который наиболее важен из пяти вышеперечисленных инструментов, работает в том же окне, что и Редактор. Внешний отладчик делает все, что делает встроенный и выполняет дополнительные функции. Он более быстр и мощен, чем встроенный. Однако он не так удобен в использовании, главным образом из-за необходимости покидать среду Delphi.

Внешний компилятор (DCC.EXE) полезен, в основном, если необходимо скомпилировать приложение перед отладкой его во внешнем отладчике. Возможно создать и откомпилировать программу на Delphi, используя только DCC.EXE и еще одну программу CONVERT.EXE, которая поможет создать формы. Однако, данный подход неудобен для большинства программистов.

WinSight (WS.EXE) интересен преимущественно для опытных программистов в Windows. Этот инструмент используются для узких технических целей. Основная его функция – позволяет наблюдать за системой сообщений Windows. Хотя Delphi делает много для того, чтобы спрятать сложные детали данной системы сообщений от неопытных пользователей, тем не менее Windows является операционной системой, управляемой событиями. Почти все главные и второстепенные события в среде Windows принимают форму сообщений, которые рассылаются с большой интенсивностью между различными окнами на экране. Delphi дает полный доступ к сообщениям Windows и позволяет отвечать на них, как только будет нужно. В результате, опытным пользователям WinSight становится просто необходим.
      1. Стандартные компоненты


На первой странице Палитры Компонент размещены 14 объектов (рисунок 1.11) наиболее важных для использования (кнопка, списки, окно ввода и т.д.). Набор и порядок компонент на каждой странице являются конфигурируемыми. Можно добавить к имеющимся компонентам новые, изменить их количество и порядок.

Стандартные компоненты Delphi:

  • TMainMenu позволяет поместить главное меню в программу. При помещении TMainMenu на форму это выглядит не как меню, а как обычная иконка. Иконки данного типа называют «невизуальными компонентами», поскольку они невидимы во время выполнения программы. Создание меню включает три шага:

    1. помещение TMainMenu на форму,

    2. вызов Дизайнера Меню через свойство Items в Инспекторе Объектов,

    3. определение пунктов меню в Дизайнере Меню.

  • TPopupMenu позволяет создавать всплывающие меню. Этот тип меню появляется по щелчку правой кнопки мыши.

  • TLabel служит для отображения текста на экране. Для изменения шрифта и цвета метки необходимо дважды щелкнуть на свойство Font в Инспекторе Объектов. Изменить данные свойства возможно и во время выполнения программы.

  • TEdit - стандартный управляющий элемент Windows для ввода. Он может быть использован для отображения короткого фрагмента текста и позволяет пользователю вводить текст во время выполнения программы.

  • TMemo - иная форма TEdit. Подразумевает работу с большими текстами. TMemo может переносить слова, сохранять в Clipboard фрагменты текста и восстанавливать их, и другие основные функции редактора. TMemo имеет ограничения на объем текста в 32Кб, это составляет 10-20 страниц.

  • TButton позволяет выполнить какие-либо действия при нажатии кнопки во время выполнения программы. Поместив TButton на форму, по двойному щелчку можно создать заготовку обработчика события нажатия кнопки. Далее нужно заполнить заготовку кодом (подчеркнуто то, что нужно написать вручную):

procedure TForm1.Button1Click(Sender: TObject);

begin MessageDlg('Are you there?',mtConfirmation,mbYesNoCancel,0); end;

  • TCheckBox отображает строку текста с маленьким окошком рядом. В окошке можно поставить отметку, которая означает, что что-то выбрано.

  • TRadioButton позволяет выбрать только одну опцию из нескольких.

  • TListBox нужен для показа прокручиваемого списка.

  • TComboBox во многом напоминает ListBox, за исключением того, что позволяет водить информацию в маленьком поле ввода сверху ListBox.

  • TScrollbar - полоса прокрутки, появляется автоматически в объектах редактирования при необходимости прокрутки текста для просмотра.

  • TGroupBox используется для визуальных целей и для указания Windows, каков порядок перемещения по компонентам на форме (при нажатии клавиши TAB).

  • TPanel - управляющий элемент, похожий на TGroupBox, используется в декоративных целях. Чтобы использовать TPanel, нужно просто поместить его на форму и затем положить другие компоненты на него. Теперь при перемещении TPanel будут передвигаться и эти компоненты. TPanel используется также для создания линейки инструментов и окна статуса.

  • TScrollBox представляет место на форме, которое можно скроллировать в вертикальном и горизонтальном направлениях. Используется в случаях, когда понадобится прокручивать только часть формы.


1   2   3   4   5   6   7   8   9

Похожие:

И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconПрограмма  дисциплины  «Объектно-ориентированное  программирование»  со
Дисциплина  (курс)  Объектно-ориентированное  программирование  имеет  своей  це
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум icon“Объектно-ориентированное программирование”
Целью данной учебной дисциплины является обучение программированию на языке Си++ с использованием принципов объектно-ориентированного...
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconИнтегрированная среда разработки языка Visual Basic
...
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум icon        биологические основы   лесного хозяйства      Лабораторный  практикум                
Лабораторный практикум для подготовки бакалавра   по профессионально-образовательной программе 250300  
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум icon      Факультет бизнес-информатика      Объектно-ориентированный анализ и программирование 
Основная цель, которую необходимо достичь в результате обучения дисциплине  Объектно
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconКонспект  лекций, лабораторный  практикум, практикум, контрольно-измерительные  материа
У66   Управляемые  конструкции  и  системы. [Электронный  ресурс] :  метод.  ука
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconЛабораторный практикум  по физике 
Предисловие    8 
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconЛабораторный практикум  по общей химии 
Введение  5 
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconЛабораторный практикум   по молекулярной физике,   термодинамике  
Введение  5 
И. В. Сухарева объектно-ориентированное программирование лабораторный практикум iconЛабораторный практикум   по курсу общей
Обработка результатов измерений   4 
Разместите кнопку на своём сайте:
TopReferat


База данных защищена авторским правом ©topreferat.znate.ru 2012
обратиться к администрации
ТопРеферат
Главная страница